cryptonas/packages/perl-clearsilver_debian_packaging.patch
lars 59098ce7cb perl-clearsilver debian package
cryptobox debian package
directories restructured
2005-11-30 23:50:10 +00:00

60 lines
2.4 KiB
Diff

# how to build the perl-clearsilver package:
# apt-get source clearsilver
# cat THIS_FILE | patch -p0
# cd clearsilver-*
# debian/rules binary
diff -ruN clearsilver-0.9.13.orig/debian/control clearsilver-0.9.13/debian/control
--- clearsilver-0.9.13.orig/debian/control 2005-11-30 23:09:24.000000000 +0100
+++ clearsilver-0.9.13/debian/control 2005-11-30 23:38:10.000000000 +0100
@@ -39,3 +39,13 @@
This Debian package is an empty dummy package that always depends on
a package built for Debian's default Python version.
+Package: perl-clearsilver
+Architecture: all
+Section: perl
+Priority: optional
+Depends: perl (>= 5.6)
+Description: perl bindings for clearsilver
+ Clearsilver is a fast, powerful, and language-neutral HTML template system.
+ In both static content sites and dynamic HTML applications, it
+ provides a separation between presentation code and application logic which
+ makes working with your project easier.
diff -ruN clearsilver-0.9.13.orig/debian/rules clearsilver-0.9.13/debian/rules
--- clearsilver-0.9.13.orig/debian/rules 2005-11-30 23:09:24.000000000 +0100
+++ clearsilver-0.9.13/debian/rules 2005-11-30 23:49:57.000000000 +0100
@@ -9,7 +9,7 @@
include /usr/share/cdbs/1/rules/simple-patchsys.mk
DEB_CONFIGURE_EXTRA_FLAGS := --with-python=/usr/bin/python2.3 \
- --disable-perl \
+ --with-perl=/usr/bin/perl \
--disable-ruby \
--disable-csharp \
--disable-apache \
@@ -18,6 +18,7 @@
CFLAGS += -fPIC
DEB_MAKE_INSTALL_TARGET := install DESTDIR=$(CURDIR)/debian/tmp
+DEB_SHLIBDEPS_INCLUDE_perl-clearsilver := debian/perl-clearsilver/usr/lib/perl5
DEB_SHLIBDEPS_INCLUDE_python2.3-clearsilver := debian/python2.3-clearsilver/usr/lib/python2.3/site-packages
build/python2.3-clearsilver::
@@ -27,3 +28,16 @@
binary-post-install/python2.3-clearsilver::
dh_movefiles --package=python2.3-clearsilver usr/lib/python2.3
+
+build/perl-clearsilver::
+ install -d debian/tmp/usr/lib/perl5
+ install -d debian/tmp/usr/lib/perl5/auto/ClearSilver
+ install -m644 $(DEB_BUILDDIR)/perl/ClearSilver.pm \
+ debian/tmp/usr/lib/perl5/ClearSilver.pm
+ install -m755 $(DEB_BUILDDIR)/perl/blib/arch/auto/ClearSilver/ClearSilver.so \
+ debian/tmp/usr/lib/perl5/auto/ClearSilver/ClearSilver.so
+ install -m644 $(DEB_BUILDDIR)/perl/ClearSilver.bs \
+ debian/tmp/usr/lib/perl5/auto/ClearSilver/ClearSilver.bs
+
+binary-post-install/perl-clearsilver::
+ dh_movefiles --package=perl-clearsilver usr/lib/perl5